Get in touch
Back
Resolved

Software configuration error on munzeeblog.com

Started 30 Aug at 08:51am CDT.

Munzee Blog
Created

We have discovered the issue and applied a patch, and will be monitoring munzeeblog.com throughout the day.

Posted 30 Aug at 08:51am CDT.