Resolved
We've applied a fix to the store, so adding products to your cart and checking out should work again.
If you attempted to check out earlier, you may need to clear your cart and re-add your items to be able to check out.
Apologies for the inconvenience caused.
Posted .
Created
We're aware that the Freeze Tag Store is currently giving errors when trying to add items to your cart or check out - we are looking into the issue.
Posted .
Resolved